5710 C# Programming Manual: D:/5710/C# Directory Reference

5710 C# Programming Manual
C# Directory Reference

Files

file | JY5710AOTask.cs
file | JY5710DITask.cs
file | JY5710DOTask.cs
Generated by doxygen 1.9.1


5710 C# Programming Manual: D:/5710/C#/JY5710AOTask.cs File Reference

Classes | Namespaces | Enumerations
JY5710AOTask.cs File Reference

Classes

class | JY5710.JY5710AOTask
JY5710 Analog Ouput Task More...
class | JY5710.AOChannel
AO Channel parameter class . More...
class | JY5710.AOSampleClock
AO Sample clock configuration class More...
class | JY5710.AOExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5710.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5710.AODigitalTrigger
AO Digital trigger . More...
class | JY5710.AOSignalExport
AO Signal Export Class More...

Namespaces

namespace JY5710

Enumerations

enum class | JY5710.AODigitalTriggerEdge { JY5710.Rising , JY5710.Falling }
AO Digital Trigger Edge More...
enum class JY5710.AODigitalTriggerSource {
JY5710.PFI0 =1 , JY5710.PFI1 =2 , JY5710.PFI2 =3 , JY5710.PXI_Trig0 = 8 ,
JY5710.PXI_Trig1 = 9 , JY5710.PXI_Trig2 = 10 , JY5710.PXI_Trig3 = 11 , JY5710.PXI_Trig4 = 12 ,
JY5710.PXI_Trig5 = 13 , JY5710.PXI_Trig6 = 14 , JY5710.PXI_Trig7 = 15
}
AO Digital trigger source. More...
enum class | JY5710.AOMode { JY5710.Single = 3 , JY5710.Finite = 0 , JY5710.ContinuousNoWrapping = 2 , JY5710.ContinuousWrapping = 1 }
AOMode More...
enum class | JY5710.AOSampleClockSource { JY5710.Internal , JY5710.External }
AO Sample Clock Source More...
enum class | JY5710.AOSignalExportSource { JY5710.StartTrig = JY5710Import.JY5710_AO_StartTrig , JY5710.SampleClock = JY5710Import.JY5710_AO_SampleClock }
SourceSignal More...
enum class | JY5710.AOTriggerType { JY5710.Immediate = JY5710Import.JY5710_TriggerType_Immediately , JY5710.Digital = JY5710Import.JY5710_TriggerType_Digital , JY5710.Soft = JY5710Import.JY5710_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5710.ClockTerminal {
JY5710.PFI0 = 1 , JY5710.PFI1 = 2 , JY5710.PFI2 = 3 , JY5710.PXI_Trig0 = 8 ,
JY5710.PXI_Trig1 = 9 , JY5710.PXI_Trig2 = 10 , JY5710.PXI_Trig3 = 11 , JY5710.PXI_Trig4 = 12 ,
JY5710.PXI_Trig5 = 13 , JY5710.PXI_Trig6 = 14 , JY5710.PXI_Trig7 = 15
}
Clock Terminal More...
enum class JY5710.SignalExportDestination {
JY5710.PFI0 = JY5710Import.JY5710_PFI0_OUT , JY5710.PFI1 = JY5710Import.JY5710_PFI1_OUT , JY5710.PFI2 = JY5710Import.JY5710_PFI2_OUT , JY5710.PXI_Trig0 = JY5710Import.JY5710_PXITrig0_OUT ,
JY5710.PXI_Trig1 = JY5710Import.JY5710_PXITrig1_OUT , JY5710.PXI_Trig2 = JY5710Import.JY5710_PXITrig2_OUT , JY5710.PXI_Trig3 = JY5710Import.JY5710_PXITrig3_OUT , JY5710.PXI_Trig4 = JY5710Import.JY5710_PXITrig4_OUT ,
JY5710.PXI_Trig5 = JY5710Import.JY5710_PXITrig5_OUT , JY5710.PXI_Trig6 = JY5710Import.JY5710_PXITrig6_OUT , JY5710.PXI_Trig7 = JY5710Import.JY5710_PXITrig7_OUT
}
Output DestinationTerminal More...


5710 C# Programming Manual: JY5710.JY5710AOTask Class Reference

  • JY5710
  • JY5710AOTask
Public Member Functions | Properties | List of all members
JY5710.JY5710AOTask Class Reference

JY5710 Analog Ouput Task More...

Public Member Functions

JY5710AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number More...
JY5710AOTask (string boardName)
Constructor. More...
void | AddChannel (int chnId)
Add one channel. More...
void | AddChannel (int[] chnsId)
Add a group of channels. More...
void | RemoveChannel (int chnId)
Delete the specified channel number. More...
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel. More...
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data. More...
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer. More...
void | WriteRawData (ushort[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel. More...
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data. More...
void | WriteRawData (ushort[] buf, int timeout=10000)
Write one channel raw Data to AO buffer. More...
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register . More...
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single More...
void | WriteRawSinglePoint (ushort[] writeValues)
write one raw sample to all channels in register . More...
void | WriteRawSinglePoint (ushort writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
void | Start ()
Start AO task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop AO task . More...

Properties

List< AOChannel > | Channels [get]
List of AO channels,(5711 support 32 channels) More...
AOMode | Mode [get, set]
Mode of AO Task. More...
double | UpdateRate [get, set]
AO 32 channels are divided into 16 banks, and one bank contains 2 channels. More...
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value. More...
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer. More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AOSampleClock | SampleClock [get, set]
AO Sample Clock Configuration . More...
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration. More...
bool | DisableCalibration [get, set]
Disalble calibration. More...
AOSignalExport | SignalExport [get, set]
Export AO Signal More...
JY5710Device | Device [get]
Device More...

Detailed Description

JY5710 Analog Ouput Task

Constructor & Destructor Documentation

◆ JY5710AOTask() [1/2]

JY5710.JY5710AOTask.JY5710AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number

Parameters
slotNum Card slot number.

◆ JY5710AOTask() [2/2]

JY5710.JY5710AOTask.JY5710AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710.JY5710AOTask.AddChannel ( int chnId )

Add one channel.

Parameters
chnId channel's physical number ，chnId=-1, add all channels。（5711 support 32 channels）

◆ AddChannel() [2/2]

void JY5710.JY5710AOTask.AddChannel ( int[] chnsId )

Add a group of channels.

Parameters
chnsId a group of channel physical numbers。（5711 support 32 channels）

◆ RemoveChannel()

void JY5710.JY5710AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5710.JY5710AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5710.JY5710AOTask.Start ( )

Start AO task .

◆ Stop()

void JY5710.JY5710AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5710.JY5710AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5710.JY5710AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5710.JY5710AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5710.JY5710AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JY5710.JY5710AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JY5710.JY5710AOTask.WriteRawData | ( | ushort | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JY5710.JY5710AOTask.WriteRawData | ( | ushort[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5710.JY5710AOTask.WriteRawSinglePoint | ( | ushort | writeValue,
 |  | int | channel
 | ) |  |

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5710.JY5710AOTask.WriteRawSinglePoint ( ushort[] writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5710.JY5710AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel
 | ) |  |

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5710.JY5710AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JY5710.JY5710AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JY5710.JY5710AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JY5710.JY5710AOTask.Channels
get

List of AO channels,(5711 support 32 channels)

◆ Device

JY5710Device JY5710.JY5710AOTask.Device
get

Device

◆ DisableCalibration

bool JY5710.JY5710AOTask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AOMode JY5710.JY5710AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JY5710.JY5710AOTask.SampleClock
getset

AO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5710.JY5710AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JY5710.JY5710AOTask.SignalExport
getset

Export AO Signal

◆ TransferedSamples

ulong JY5710.JY5710AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JY5710.JY5710AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JY5710.JY5710AOTask.UpdateRate
getset

AO 32 channels are divided into 16 banks, and one bank contains 2 channels.

If each bank is less than or equal to one channel, the maximum AO update rate is 2M; if the number of channels in any bank is greater than 1, the maximum AO update rate is 1M

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY5710.AOChannel Class Reference

AO Channel parameter class . More...

Properties

int ChannelID [get]
AO channel ID. More...

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JY5710.AOChannel.ChannelID
get

AO channel ID.

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JY5710.AOSampleClock Class Reference

AO Sample clock configuration class More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source. More...
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External. More...

Detailed Description

AO Sample clock configuration class

Property Documentation

◆ External

AOExternalSampleClock JY5710.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JY5710.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JY5710.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5710.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5710.AOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY5710.AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type. More...
AODigitalTrigger | Digital [get, set]
AO Digital Trigger. More...

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JY5710.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5710.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY5710.AODigitalTrigger Class Reference

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source. More...
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JY5710.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5710.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: JY5710.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5710.AOSignalExport Class Reference

AO Signal Export Class More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5710.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5710.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JY5710.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5710.AOSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710AOTask.cs


5710 C# Programming Manual: D:/5710/C#/JY5710DITask.cs File Reference

Classes | Namespaces
JY5710DITask.cs File Reference

Classes

class | JY5710.JY5710DITask
JY5710DITask Class More...
class | JY5710.DIChannel
DI Channel parameter class More...

Namespaces

namespace JY5710


5710 C# Programming Manual: JY5710.JY5710DITask Class Reference

  • JY5710DITask
Public Member Functions | Properties | List of all members
JY5710.JY5710DITask Class Reference

JY5710DITask Class More...

Public Member Functions

JY5710DITask (int slotNum)
Constructor. More...
JY5710DITask (string aliasName)
Constructor. More...
void | AddChannel (int lineNum)
Add one line More...
void | AddChannel (int[] linesNum)
Add a group of line More...
void | RemoveChannel (int lineNum)
Delete the specified line number More...
void | Start ()
Start DITask More...
void | Stop ()
Stop DITask More...
void | ReadSinglePoint (ref bool readValue, int lineNum)
Specify the line reads the latest point More...
void | ReadSinglePoint (ref bool[] buf)
Each line reads the latest point More...

Properties

JY5710Device | Device [get]
Device Handle More...
List< DIChannel > | Channels [get]
List of DI channels More...

Detailed Description

JY5710DITask Class

Constructor & Destructor Documentation

◆ JY5710DITask() [1/2]

JY5710.JY5710DITask.JY5710DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JY5710DITask() [2/2]

JY5710.JY5710DITask.JY5710DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710.JY5710DITask.AddChannel ( int lineNum )

Add one line

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5710.JY5710DITask.AddChannel ( int[] linesNum )

Add a group of line

Parameters
linesNum lines number

◆ ReadSinglePoint() [1/2]

void JY5710.JY5710DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | lineNum
 | ) |  |

Specify the line reads the latest point

Parameters
readValue | read Value
lineNum | Specify the line to read

◆ ReadSinglePoint() [2/2]

void JY5710.JY5710DITask.ReadSinglePoint ( ref bool[] buf )

Each line reads the latest point

Parameters
buf User buffer array

◆ RemoveChannel()

void JY5710.JY5710DITask.RemoveChannel ( int lineNum )

Delete the specified line number

Parameters
lineNum line number

◆ Start()

void JY5710.JY5710DITask.Start ( )

Start DITask

◆ Stop()

void JY5710.JY5710DITask.Stop ( )

Stop DITask

Property Documentation

◆ Channels

List<DIChannel> JY5710.JY5710DITask.Channels
get

List of DI channels

◆ Device

JY5710Device JY5710.JY5710DITask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710DITask.cs


5710 C# Programming Manual: JY5710.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5710.DIChannel Class Reference

DI Channel parameter class More...

Properties

int LineNum [get, set]
Line Number More...

Detailed Description

DI Channel parameter class

Property Documentation

◆ LineNum

int JY5710.DIChannel.LineNum
getset

Line Number

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710DITask.cs


5710 C# Programming Manual: D:/5710/C#/JY5710DOTask.cs File Reference

Classes | Namespaces
JY5710DOTask.cs File Reference

Classes

class | JY5710.JY5710DOTask
JY5710 DOTask More...
class | JY5710.DOChannel
DOChannel class More...

Namespaces

namespace JY5710


5710 C# Programming Manual: JY5710.JY5710DOTask Class Reference

  • JY5710DOTask
Public Member Functions | Properties | List of all members
JY5710.JY5710DOTask Class Reference

JY5710 DOTask More...

Public Member Functions

JY5710DOTask (int slotNum)
Constructor. More...
JY5710DOTask (string aliasName)
Constructor. More...
void | AddChannel (int lineNum)
Add one line More...
void | AddChannel (int[] linesNum)
Add mulitiple lines More...
void | RemoveChannel (int lineNum)
delete the specified line number More...
void | Start ()
Start DOTask More...
void | Stop ()
Stop DOTask More...
void | WriteSinglePoint (bool writeValue, int lineNum)
write the latest point of Specify line More...
void | WriteSinglePoint (bool[] writeValues)
write the latest point More...

Properties

JY5710Device | Device [get]
Device Handle More...
List< DOChannel > | Channels [get]
List of DO channels More...

Detailed Description

JY5710 DOTask

Constructor & Destructor Documentation

◆ JY5710DOTask() [1/2]

JY5710.JY5710DOTask.JY5710DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JY5710DOTask() [2/2]

JY5710.JY5710DOTask.JY5710DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710.JY5710DOTask.AddChannel ( int lineNum )

Add one line

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5710.JY5710DOTask.AddChannel ( int[] linesNum )

Add mulitiple lines

Parameters
linesNum lines number

◆ RemoveChannel()

void JY5710.JY5710DOTask.RemoveChannel ( int lineNum )

delete the specified line number

Parameters
lineNum line number

◆ Start()

void JY5710.JY5710DOTask.Start ( )

Start DOTask

◆ Stop()

void JY5710.JY5710DOTask.Stop ( )

Stop DOTask

◆ WriteSinglePoint() [1/2]

void JY5710.JY5710DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | lineNum
 | ) |  |

write the latest point of Specify line

Parameters
writeValue | write Value
lineNum | Specify the line to write

◆ WriteSinglePoint() [2/2]

void JY5710.JY5710DOTask.WriteSinglePoint ( bool[] writeValues )

write the latest point

Parameters
writeValues User buffer array

Property Documentation

◆ Channels

List<DOChannel> JY5710.JY5710DOTask.Channels
get

List of DO channels

◆ Device

JY5710Device JY5710.JY5710DOTask.Device
get

Device Handle

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710DOTask.cs


5710 C# Programming Manual: JY5710.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5710.DOChannel Class Reference

DOChannel class More...

Properties

int LineNum [get, set]
line Number More...

Detailed Description

DOChannel class

Property Documentation

◆ LineNum

int JY5710.DOChannel.LineNum
getset

line Number

The documentation for this class was generated from the following file:
  • D:/5710/C#/JY5710DOTask.cs


5710 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5710 |
C JY5710AOTask | JY5710 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY5710DITask | JY5710DITask Class
C DIChannel | DI Channel parameter class
C JY5710DOTask | JY5710 DOTask
C DOChannel | DOChannel class


5710 C# Programming Manual: Member List

  • AOChannel
JY5710.AOChannel Member List

This is the complete list of members for JY5710.AOChannel, including all inherited members.

ChannelID JY5710.AOChannel


5710 C# Programming Manual: Member List

  • AODigitalTrigger
JY5710.AODigitalTrigger Member List

This is the complete list of members for JY5710.AODigitalTrigger, including all inherited members.

Edge | JY5710.AODigitalTrigger
Source | JY5710.AODigitalTrigger


5710 C# Programming Manual: Member List

  • AOExternalSampleClock
JY5710.AOExternalSampleClock Member List

This is the complete list of members for JY5710.AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5710.AOExternalSampleClock
Terminal | JY5710.AOExternalSampleClock


5710 C# Programming Manual: Member List

  • AOSampleClock
JY5710.AOSampleClock Member List

This is the complete list of members for JY5710.AOSampleClock, including all inherited members.

External | JY5710.AOSampleClock
Source | JY5710.AOSampleClock


5710 C# Programming Manual: Member List

  • AOSignalExport
JY5710.AOSignalExport Member List

This is the complete list of members for JY5710.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5710.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JY5710.AOSignalExport
Clear(SignalExportDestination destination) | JY5710.AOSignalExport
ClearAll() | JY5710.AOSignalExport


5710 C# Programming Manual: Member List

  • AOTrigger
JY5710.AOTrigger Member List

This is the complete list of members for JY5710.AOTrigger, including all inherited members.

Digital | JY5710.AOTrigger
Type | JY5710.AOTrigger


5710 C# Programming Manual: Member List

  • DIChannel
JY5710.DIChannel Member List

This is the complete list of members for JY5710.DIChannel, including all inherited members.

LineNum JY5710.DIChannel


5710 C# Programming Manual: Member List

  • DOChannel
JY5710.DOChannel Member List

This is the complete list of members for JY5710.DOChannel, including all inherited members.

LineNum JY5710.DOChannel


5710 C# Programming Manual: Member List

  • JY5710AOTask
JY5710.JY5710AOTask Member List

This is the complete list of members for JY5710.JY5710AOTask, including all inherited members.

AddChannel(int chnId) | JY5710.JY5710AOTask
AddChannel(int[] chnsId) | JY5710.JY5710AOTask
AvaliableLenInSamples | JY5710.JY5710AOTask
BufLenInSamples | JY5710.JY5710AOTask
Channels | JY5710.JY5710AOTask
Device | JY5710.JY5710AOTask
DisableCalibration | JY5710.JY5710AOTask
JY5710AOTask(int slotNum) | JY5710.JY5710AOTask
JY5710AOTask(string boardName) | JY5710.JY5710AOTask
Mode | JY5710.JY5710AOTask
RemoveChannel(int chnId) | JY5710.JY5710AOTask
SampleClock | JY5710.JY5710AOTask
SamplesToUpdate | JY5710.JY5710AOTask
SendSoftwareTrigger() | JY5710.JY5710AOTask
SignalExport | JY5710.JY5710AOTask
Start() | JY5710.JY5710AOTask
Stop() | JY5710.JY5710AOTask
TransferedSamples | JY5710.JY5710AOTask
Trigger | JY5710.JY5710AOTask
UpdateRate | JY5710.JY5710AOTask
WaitUntilDone(int timeout=-1) | JY5710.JY5710AOTask
WriteData(double[,] buf, int timeout=10000) | JY5710.JY5710AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5710.JY5710AOTask
WriteData(double[] buf, int timeout=10000) | JY5710.JY5710AOTask
WriteRawData(ushort[,] buf, int timeout=10000) | JY5710.JY5710AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5710.JY5710AOTask
WriteRawData(ushort[] buf, int timeout=10000) | JY5710.JY5710AOTask
WriteRawSinglePoint(ushort[] writeValues) | JY5710.JY5710AOTask
WriteRawSinglePoint(ushort writeValue, int channel) | JY5710.JY5710AOTask
WriteSinglePoint(double[] writeValues) | JY5710.JY5710AOTask
WriteSinglePoint(double writeValue, int channel) | JY5710.JY5710AOTask


5710 C# Programming Manual: Member List

  • JY5710DITask
JY5710.JY5710DITask Member List

This is the complete list of members for JY5710.JY5710DITask, including all inherited members.

AddChannel(int lineNum) | JY5710.JY5710DITask
AddChannel(int[] linesNum) | JY5710.JY5710DITask
Channels | JY5710.JY5710DITask
Device | JY5710.JY5710DITask
JY5710DITask(int slotNum) | JY5710.JY5710DITask
JY5710DITask(string aliasName) | JY5710.JY5710DITask
ReadSinglePoint(ref bool readValue, int lineNum) | JY5710.JY5710DITask
ReadSinglePoint(ref bool[] buf) | JY5710.JY5710DITask
RemoveChannel(int lineNum) | JY5710.JY5710DITask
Start() | JY5710.JY5710DITask
Stop() | JY5710.JY5710DITask


5710 C# Programming Manual: Member List

  • JY5710DOTask
JY5710.JY5710DOTask Member List

This is the complete list of members for JY5710.JY5710DOTask, including all inherited members.

AddChannel(int lineNum) | JY5710.JY5710DOTask
AddChannel(int[] linesNum) | JY5710.JY5710DOTask
Channels | JY5710.JY5710DOTask
Device | JY5710.JY5710DOTask
JY5710DOTask(int slotNum) | JY5710.JY5710DOTask
JY5710DOTask(string aliasName) | JY5710.JY5710DOTask
RemoveChannel(int lineNum) | JY5710.JY5710DOTask
Start() | JY5710.JY5710DOTask
Stop() | JY5710.JY5710DOTask
WriteSinglePoint(bool writeValue, int lineNum) | JY5710.JY5710DOTask
WriteSinglePoint(bool[] writeValues) | JY5710.JY5710DOTask


5710 C# Programming Manual: Class Index

Class Index
A | D | J
A
AOChannel (JY5710)
AODigitalTrigger (JY5710)
AOExternalSampleClock (JY5710)
AOSampleClock (JY5710)
AOSignalExport (JY5710)
AOTrigger (JY5710)
D
DIChannel (JY5710)
DOChannel (JY5710)
J
JY5710AOTask (JY5710)
JY5710DITask (JY5710)
JY5710DOTask (JY5710)


5710 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5710


5710 C# Programming Manual: D:/5710 Directory Reference

  • D:
  • 5710
5710 Directory Reference

Directories

directory C#


5710 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 5710
▼ C#
JY5710AOTask.cs
JY5710DITask.cs
JY5710DOTask.cs


5710 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY5710.AOSignalExport
  • AddChannel() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • AvaliableLenInSamples : JY5710.JY5710AOTask

- b -

  • BufLenInSamples : JY5710.JY5710AOTask

- c -

  • ChannelID : JY5710.AOChannel
  • Channels : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Clear() : JY5710.AOSignalExport
  • ClearAll() : JY5710.AOSignalExport

- d -

  • Device : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Digital : JY5710.AOTrigger
  • DisableCalibration : JY5710.JY5710AOTask

- e -

  • Edge : JY5710.AODigitalTrigger
  • ExpectedRate : JY5710.AOExternalSampleClock
  • External : JY5710.AOSampleClock

- j -

  • JY5710AOTask() : JY5710.JY5710AOTask
  • JY5710DITask() : JY5710.JY5710DITask
  • JY5710DOTask() : JY5710.JY5710DOTask

- l -

  • LineNum : JY5710.DIChannel , JY5710.DOChannel

- m -

  • Mode : JY5710.JY5710AOTask

- r -

  • ReadSinglePoint() : JY5710.JY5710DITask
  • RemoveChannel() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask

- s -

  • SampleClock : JY5710.JY5710AOTask
  • SamplesToUpdate : JY5710.JY5710AOTask
  • SendSoftwareTrigger() : JY5710.JY5710AOTask
  • SignalExport : JY5710.JY5710AOTask
  • Source : JY5710.AODigitalTrigger , JY5710.AOSampleClock
  • Start() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Stop() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask

- t -

  • Terminal : JY5710.AOExternalSampleClock
  • TransferedSamples : JY5710.JY5710AOTask
  • Trigger : JY5710.JY5710AOTask
  • Type : JY5710.AOTrigger

- u -

  • UpdateRate : JY5710.JY5710AOTask

- w -

  • WaitUntilDone() : JY5710.JY5710AOTask
  • WriteData() : JY5710.JY5710AOTask
  • WriteRawData() : JY5710.JY5710AOTask
  • WriteRawSinglePoint() : JY5710.JY5710AOTask
  • WriteSinglePoint() : JY5710.JY5710AOTask , JY5710.JY5710DOTask


5710 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5710.AOSignalExport
  • AddChannel() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask

- c -

  • Clear() : JY5710.AOSignalExport
  • ClearAll() : JY5710.AOSignalExport

- j -

  • JY5710AOTask() : JY5710.JY5710AOTask
  • JY5710DITask() : JY5710.JY5710DITask
  • JY5710DOTask() : JY5710.JY5710DOTask

- r -

  • ReadSinglePoint() : JY5710.JY5710DITask
  • RemoveChannel() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask

- s -

  • SendSoftwareTrigger() : JY5710.JY5710AOTask
  • Start() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Stop() : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask

- w -

  • WaitUntilDone() : JY5710.JY5710AOTask
  • WriteData() : JY5710.JY5710AOTask
  • WriteRawData() : JY5710.JY5710AOTask
  • WriteRawSinglePoint() : JY5710.JY5710AOTask
  • WriteSinglePoint() : JY5710.JY5710AOTask , JY5710.JY5710DOTask


5710 C# Programming Manual: Class Members - Properties

  • AvaliableLenInSamples : JY5710.JY5710AOTask
  • BufLenInSamples : JY5710.JY5710AOTask
  • ChannelID : JY5710.AOChannel
  • Channels : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Device : JY5710.JY5710AOTask , JY5710.JY5710DITask , JY5710.JY5710DOTask
  • Digital : JY5710.AOTrigger
  • DisableCalibration : JY5710.JY5710AOTask
  • Edge : JY5710.AODigitalTrigger
  • ExpectedRate : JY5710.AOExternalSampleClock
  • External : JY5710.AOSampleClock
  • LineNum : JY5710.DIChannel , JY5710.DOChannel
  • Mode : JY5710.JY5710AOTask
  • SampleClock : JY5710.JY5710AOTask
  • SamplesToUpdate : JY5710.JY5710AOTask
  • SignalExport : JY5710.JY5710AOTask
  • Source : JY5710.AODigitalTrigger , JY5710.AOSampleClock
  • Terminal : JY5710.AOExternalSampleClock
  • TransferedSamples : JY5710.JY5710AOTask
  • Trigger : JY5710.JY5710AOTask
  • Type : JY5710.AOTrigger
  • UpdateRate : JY5710.JY5710AOTask


5710 C# Programming Manual: Main Page

5710 C# Programming Manual Documentation


5710 C# Programming Manual: JY5710 Namespace Reference

Classes | Enumerations
JY5710 Namespace Reference

Classes

class | JY5710AOTask
JY5710 Analog Ouput Task More...
class | AOChannel
AO Channel parameter class . More...
class | AOSampleClock
AO Sample clock configuration class More...
class | AOExternalSampleClock
External Sample Clock Configuration Class More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class More...
class | JY5710DITask
JY5710DITask Class More...
class | DIChannel
DI Channel parameter class More...
class | JY5710DOTask
JY5710 DOTask More...
class | DOChannel
DOChannel class More...

Enumerations

enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge More...
enum class AODigitalTriggerSource {
PFI0 =1 , PFI1 =2 , PFI2 =3 , PXI_Trig0 = 8 ,
PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 , PXI_Trig4 = 12 ,
PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
AO Digital trigger source. More...
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source More...
enum class | AOSignalExportSource { StartTrig = JY5710Import.JY5710_AO_StartTrig , SampleClock = JY5710Import.JY5710_AO_SampleClock }
SourceSignal More...
enum class | AOTriggerType { Immediate = JY5710Import.JY5710_TriggerType_Immediately , Digital = JY5710Import.JY5710_TriggerType_Digital , Soft = JY5710Import.JY5710_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class ClockTerminal {
PFI0 = 1 , PFI1 = 2 , PFI2 = 3 , PXI_Trig0 = 8 ,
PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 , PXI_Trig4 = 12 ,
PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
Clock Terminal More...
enum class SignalExportDestination {
PFI0 = JY5710Import.JY5710_PFI0_OUT , PFI1 = JY5710Import.JY5710_PFI1_OUT , PFI2 = JY5710Import.JY5710_PFI2_OUT , PXI_Trig0 = JY5710Import.JY5710_PXITrig0_OUT ,
PXI_Trig1 = JY5710Import.JY5710_PXITrig1_OUT , PXI_Trig2 = JY5710Import.JY5710_PXITrig2_OUT , PXI_Trig3 = JY5710Import.JY5710_PXITrig3_OUT , PXI_Trig4 = JY5710Import.JY5710_PXITrig4_OUT ,
PXI_Trig5 = JY5710Import.JY5710_PXITrig5_OUT , PXI_Trig6 = JY5710Import.JY5710_PXITrig6_OUT , PXI_Trig7 = JY5710Import.JY5710_PXITrig7_OUT
}
Output DestinationTerminal More...

Enumeration Type Documentation

◆ AODigitalTriggerEdge

enum JY5710.AODigitalTriggerEdge
strong

AO Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ AODigitalTriggerSource

enum JY5710.AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trig4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7

◆ AOMode

enum JY5710.AOMode
strong

AOMode

Enumerator
Single | Single
Finite | Finite
ContinuousNoWrapping | ContinuousNoWrapping
ContinuousWrapping | ContinuousWrapping

◆ AOSampleClockSource

enum JY5710.AOSampleClockSource
strong

AO Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ AOSignalExportSource

enum JY5710.AOSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | AO_StartTrig
SampleClock | AO_SampleClock

◆ AOTriggerType

enum JY5710.AOTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ ClockTerminal

enum JY5710.ClockTerminal
strong

Clock Terminal

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PXI_Trig0 | PXITrigger_0
PXI_Trig1 | PXITrigger_1
PXI_Trig2 | PXITrigger_2
PXI_Trig3 | PXITrigger_3
PXI_Trig4 | PXITrigger_4
PXI_Trig5 | PXITrigger_5
PXI_Trig6 | PXITrigger_6
PXI_Trig7 | PXITrigger_7

◆ SignalExportDestination

enum JY5710.SignalExportDestination
strong

Output DestinationTerminal

Enumerator
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trig4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7


5710 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • AODigitalTriggerEdge : JY5710
  • AODigitalTriggerSource : JY5710
  • AOMode : JY5710
  • AOSampleClockSource : JY5710
  • AOSignalExportSource : JY5710
  • AOTriggerType : JY5710
  • ClockTerminal : JY5710
  • SignalExportDestination : JY5710


5710 C# Programming Manual: Package Functions

  • AODigitalTriggerEdge : JY5710
  • AODigitalTriggerSource : JY5710
  • AOMode : JY5710
  • AOSampleClockSource : JY5710
  • AOSignalExportSource : JY5710
  • AOTriggerType : JY5710
  • ClockTerminal : JY5710
  • SignalExportDestination : JY5710


5710 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5710 |
C JY5710AOTask | JY5710 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY5710DITask | JY5710DITask Class
C DIChannel | DI Channel parameter class
C JY5710DOTask | JY5710 DOTask
C DOChannel | DOChannel class